Deals

Deals are the new sales deal for your Organisation that you strike with your prospects. You can keep track off all your Deals based on their stages in the sales pipeline.

Adding new Deals

In Joforce CRM, you can create Deals,

  • Adding Deal info Manually

    • Click on + Add Deal button in the List view

    • Provide the necessary details

    • Click on Save
  • Using Quick Create

    • It lets you to quickly add Deal Information from anywhere in Joforce CRM.

    • Click on the + icon in the top Quick Actions Menu

    • Choose Deal from the drop down

    • In the Quick Create Deal popup, add the related information

    • Once done, hit Save

    • You can also access the complete Deal Form right from here by clicking on Go to full form.
  • Importing Deals from Existing Files

    • You can get all your existing Deal information from different sources inside Joforce CRM, with a built-in Import option. Gather the list of all your Deal information, convert it into a CSV file and import all in one in just a click.
  • Converting a Lead

    • Once your Lead are qualified as a potential prospects, you can convert them into Deal.

      • Go to the detail view of the lead and click on Convert Lead in the top menu.

      • In the Convert Lead pop, the lead data are copied to the corresponding Deal data(if added the Lead data properly).

      • You can also change the information as per your needs

      • Finally click Save
    • Once you hit save, new records are created in Deals and remove records from Leads. The data creation and the information transfer from Lead to Deal done based on Mapping Section.

Default Deal fields

By default Joforce CRM offers you with a List of fields, to add the Contact related information into Joforce CRM.

You can easily add custom fields to your contacts module to add more information about your contacts.

Default Deal Views

Joforce CRM offers you with 2 differnet types of views for Deals

  • Forecast View (Kanban view)

    • Displays all the Deals based on their stages in the sales pipeline

    • You can drag & drop fields to move the Deals across different stages

    • Click on an Deal will take you to the detail of the Deal

    • You can also get the number of Deals in each and every pipeline stage and the total deal value, this helps you to better visualize the deal progress within your Hawksales.
deal-kanban-view
  • List View

    • As like any other module in Joforce CRM

Converting Deals to Project

Whenever you won a new Deal, you can convert them into a new project and efficiently track it’s progress.

  • Go to the detail view of the Deal and click on Convert Project in the top menu.

  • In the Convert Deal overlay, the Deal Name is copied to the corresponding Project data(if added the Lead data properly).

    • You can also change the information as per your needs

    • Finally click Save
  • Once you hit save, new records are created in Project and remove records from Deal. The data creation and the information transfer from Deal to Project done based on Mapping.

Managing records in Deal

Common action performed

  • Click on List text box in the top → click on Create New option beside the LISTS to create custom filters.

  • Click on Import → To import all your existing Deal information

  • Click on More

    • Fields & Layout → To configure the module fields and customize the field layouts. Module Layouts & Fields

    • Workflows → To add workflows related to your Task and Events.

    • Picklists Values → To modify the picklist values

    • Numbering → To create custom numbering for records

    • Setup Webforms → To automate the capture of prospect info into Joforce CRM

    • Deal to Project mapping → The conversion of Deal to project is based on this mapping.

    • Find Duplicates → To find duplicate in the module

    • Merge selected records → To merge the records

    • Export → To export the data to external source

Action performed in the forcast view

  • Drag & drop fields to move the Deals across different stages

  • Click on an Deal - To go to the detail view of the Deal

  • Gives you the number of Deals in each and every pipeline stage and the total deal value.

Action performed in the list view

  • Click on the Search icon → To search for records in that module

  • Click on the Box icon → To alter the header menu

  • Double click on the menu → To sort the menu.

  • Bulk Actions on multiple records → Select the desired records → click on the drop down menu in the top

    • Send Email → To send email to your prospects

    • Follow - To keep track of a record

    • Unfollow - Disable when you no longer need to keep track of a ticket

    • Add Tag → To add different tag for the selected records

    • Edit → To edit the selected records on the whole (Mass Edit)

    • Delete → To Delete the selected records(bulk deletion)

    • Comment → To add comments to selected record

Actions done on single record

  • Enable the STAR icon to follow(keep track of) a document. Disable it to unfollow.

  • Click on the drop down in the right corner of each record

    • Details → Navigate to the detail view of the record

    • Edit → To edit the record

    • Delete → To delete the selected record
  • Click on the Eye icon in the right corner of each record → To get a quick view of your record info without navigating to the detail view

Action performed in the detail view

  • Click on Add Tag below the Deal icon→ To add tag

  • Click on Follow - To keep track of a Ticket

  • Click on Edit → To edit the record

  • Click on Send Email → To send email to your prospects

  • Click on More

    • Delete → To delete the record information

    • Duplicate → To replicate the already existing record to create a new one

    • Quote →To create a new Quote related to the services

    • Invoice →To create a new Invoice related to the services

    • Sales Order → To create a new Sales Order related to the services

    • Add Event → To add new event

    • Add Task → To add new task

View/ addition of other module records related to the particular Deal

You can easily view/ add the other module records related to a specific Deal.

  • Go to the detail view of the particular record

  • Click on the appropriate module icon. It displays all the related records.

  • You can also relate a new record either

    • By selecting from the already existing records

    • By adding a new record to that module

The list of modules included are

  • Activities, Contacts, Products, Documents, Services, Quotes, Sales Order and invoice.