WP Ultimate CSV Importer Support Threads

From Smackcoders WikiPages
Jump to: navigation, search


Custom Fields not importing 3.3.1

webstersnewworld Hello,

I am running PODS 2.3.18. i have created a custom post type. I have 10 fields created by PODS.
At the moment i am trying to import a CSV file.
wp Ultimate CSV Importer Will import the tittle and description for the first line from my CSV, when it gets the a field with numbers, it says "fieldname empty" and stops.
Other info that may be relevant:
- There are decimal points in the numbers
- Some number are "0"
- I am importing from the custom post tab
- My Select Post Type is my custom page
- import post status Published
Any help would be appreciated.

smackcoders It was never tested or added support for PODS so far. Kindly add more details.

It may need to tested against PODS plugin fields.

websternewworld Hi smackcoders,

Could you be more specific in what details you are requesting.
I am importing from "Custom post" tab. I can upload the file.
Select Post Type - "Food" (this is custom)
Import with post status - Publish
The only 2 drop down witch import as "Post_title" and "Post_content"
All other are "add custom field" they fail.
I am importing about 4 thousand fields with
Looks like the below:
Food ID Food Description Amount Mills Age
01A20081 Wine, white, cooked Wine from a bottle 150 25.9 5
The importer will import:
"Food" food name as tittle
"Description" Food Description
Only error the Importer gives is "Amount is empty" ("XXXXX is empty")
After importing one field it stops and fails, all other fields are show "0", they should show a numeric value.

smackcoders It looks like PODS custom fields are not handled/stored similar to wordpress custom fields. May need to look into PODS code. Any how as far now the importer cannot handle PODS plugin data

Import featured image bug

robov First of all...

THANK you for making this wonderful plugin. It works very nice. I noticed a small bug in the file uploading code.
My csv file contains a valid link to a photo online. This foto contains the char "æ"
When I look at the uploaded file, it this character is renamed to "æ"
Now the text in the post and the actual file are no longer corresponding, so the image does not show.
However when I upload the same image to wordpress the uploaded file still contains the "æ"
Please assist

smackcoders This is because of the CSV file format. It should be converted to UTF-8 without Bom (e.g. notepad+) to handle such special character should work.

Let me know the results and post you feedback in review.

Taxonomy Import

DenisCGN Hello,

first of all, very nice plugin, and it works well.

Now I got a problem I need to insert some reviews into a new, fresh worpress installation.

There I got a Txonomy field called "Artists".

How do I import the Reviews into new Posts, and the Artists into the artist taxonomy?



smackcoders Taxonomy support is not yet added/tested. Still can you add more details like the plugin and sample csv etc? We will look into it.

auto synch from a cvs files. possible?

nonchiedercilaparola hi, i would like to know if is possible to auto synch wordpress post with a cvs files. the best thing would be that this works also whit a cvs file saved in a cloud ambient.



smackcoders No there is no such features are available.
nonchiedercilaparola thanks for the replay. I think that's this is a important features that have to be implement.


CSV's ANSI encoding causes problems with special characters

evrenk Hello,

Your plugin is a blessing: I have an entire 900+ entries Excel spreadsheet to import into two custom post types. You just saved me a month of work.

The values I have to import are in French. Excel's ANSI encoding caused strings to be cut before the first accentuated character for each one. I have opened the csv in NotePad++ and converted the encoding to UTF-8. Worked like a charm!

Maybe someone could benefit from this piece of information :)


smackcoders evrenk,

Thank you for the feedback. Really it should help others. Also kindly rate our plugin.


hansa1 Hi smackcoders,

I have Italian special Characters like "è,à".when i try to import it is not loading full text.it is breaking until this characters.please help me.i did evrenk approach ,but no luck.

evrenk Hi hansa1,

The encoding you might get at the beginning might be different. When you open the file in a text editor, play with the encoding settings until the characters appear OK and then change the encoding to UTF-8. Does it work?

Kind regards,


smackcoders Hope @hansa1 got that worked to.
eyoungquist Thanks evrenk!!! I was pulling my hair out about this issue. Perfect solution! Will make our client very happy not to have to search/replace foreign chars with html entity codes in the csv file! Great plugin, smackcoders - any chance of accepting ANSI-encoded files in the future?
LeRedac Merci beaucoup evrenk pour cette astuce !!! j'était en train de me prendre le choux grave sur cette histoire de uft8. J'ai moi aussi une base de plus de 4000 enregistrement à importer dans un post type ! La ac Notpad ++ ça marche nickel !

smackcoders, i'm confirm Your plugin is a blessing !! Thank you so much ;-)

smackcoders @ LeRedac, Merci pour votre commentaire, j'espère que vous pouvez poster votre avis qui nous aident à maintenir notre plugin grandit
smackcoders @eyoungquist, yes we do have the plan to add in upcoming versions. Check back our next release. Dont forget to pass your review as well.

Thanks for your comment.