Project Milestones

Projects Milestones refers to signal anchor like need for input, external check and more.

Adding new Project Milestone

Joforce CRM lets you to add new projects milestones in 3 different ways,

  • Adding Projects Milestone info Manually

    • Click on the + Add Project Milestone button in the List View.

    • Add the appropriate details

    • Finally, click on Save.
  • Using Quick Create Button

    • It lets you to quickly add Project Milestone info from anywhere in Joforce CRM.

    • Click on the + icon in the top Quick Actions Menu bar

    • Choose Project Milestone from the drop down

    • In the Quick Create project milestone popup, add the related information

    • Once done, hit Save

    • You can also access the complete Project Milestone Form right from here by clicking on Go to full form.
  • Importing Project Milestone from Existing Files

    • You can get all your existing Project Milestone information from different sources inside Joforce CRM. Gather the list of all your Project Milestone information from different sources and convert it into CSV file and import all in one in just a click.

Default fields for Project Milestone

By default Joforce CRM offers you with a List of fields, to add the milestone details related to your project.

project-milestone-default-field

You can easily add custom fields to your project milestone module to add more information.

Managing records in Projects Milestone

Common action performed

  • Click on List text box in the top → click on Create New option beside the LISTS to create custom filters.

  • Click on Import → To import all your existing ticket information

  • Click on More

    • Fields & Layout → To configure the module fields and customize the field layouts. Module Layouts & Fields

    • Workflows → To add workflows related to your Task and Events.

    • Picklists Values → To modify the picklist values

    • Numbering → To create custom numbering for records

    • Merge selected records → To merge the records

    • Find Duplicates → To find duplicate in the module

    • Export → To export the data to external source

Action performed in the list view

  • Click on the Search icon in the right corner of the table → To search for records in that module

  • Click on the Box icon in the right corner of the table → To alter the header menu

  • Double click on the menu → To sort the menu.

  • Bulk Actions on multiple records → Select the desired records → click on the drop down menu in the top

    • Follow - To keep track of a record

    • Unfollow - Disable when you no longer need to keep track of a milestones

    • Add Tag → To add different tag for the selected records

    • Edit → To edit the selected records on the whole (Mass Edit)

    • Delete→ To Delete the selected records(bulk deletion)

Actions done on single record

  • Enable the STAR icon to follow(keep track of) a document. Disable it to unfollow.

  • Click on the drop down in the right corner of each record

    • Details → Navigate to the detail view of the record

    • Edit → To edit the record

    • Delete → To delete the selected record
  • Click on the Eye icon in the right corner of each record → To get a quick view of your record info without navigating to the detail view

Action performed in the detail view

  • Click on Add Tag below the project milestone icon→ To add tag

  • Click on Follow - To keep track of a Project milestone

  • Click on Edit → To edit the record

  • Click on More

    • Delete → To delete the record information

    • Duplicate → To replicate the already existing record to create a new one.

View/ addition of other module records related to the particular Project Milestone

You can easily view/ add the other module records related to a specific project milestone.

  • Go to the detail view of the particular record

  • click on the appropriate module icon. It displays all the related records.

  • You can also relate a new record either

    • By selecting from the already existing records

    • By adding a new record to that module

The list of modules included are

  • Documents and Email.
project-milestone-detail-view