Documents

Joforce CRM lets you to store all your files in one place. You can group the files under different folders. Click on the Documents menu.

Creating a new folder

Joforce CRM gives you the flexibility to create different folders to group your documents.

  • Click on the List Text box in the top → Navigate to folders section → + icon beside the FOLDER left side menu

  • In the Add New Folder popup, add the Folder name and description related to the folder.

  • Click on Save.

Adding a New Document

Joforce CRM lets you to add new documents in 3 different ways. Click on the New Document in the Top right and choose the any one option out of 3 and perform the necessary changes as given below.

  1. Upload from desktop

    • Click on the New Document, choose To Joforce CRM from the drop down.

    • Select the appropriate file from your computer

    • Add the Document Title and description

    • To assign it to a different user you can choose the desired user from the drop down

    • Select the desired folder name and then click on Upload.
  2. Download from external URL

    • Click on the New Document, choose From File URL from the drop down.

    • Add the Document Title

    • Provide the URL from which the document need to be downloaded

    • To assign it to a different user you can choose the desired user from the drop down

    • Select the desired folder name and then click on Create.
  3. Manually Creating a new document

    • Click on the New Document, choose Create New Document from the drop down.

    • Add the Document Title and description

    • To assign it to a different user you can choose the desired user from the drop down

    • Select the desired folder name and then click on Save.
documents-creation

Move documents from one folder to another

To move your records from one folder to another,

  • Choose the desired document, click on drop down menu and choose Move

  • In the Please select a folder to move overlay, It displays all the available folder, choose one among them.

  • Finally click on Move.

View all the module records related to particular document

You can easily view all the records related to a specific document.

  • Go to the detail view of the particular document

  • Click on the appropriate module icon. It displays all the related records that has this particular documents.

Here is the list of modules, for which you can attach the documents

  • Contacts, Organisation, Deals, Leads, Products, Services, Projects, Quotes, Invoice, Sales Order, Purchase Order and Tickets.

Downloading Documents

Go to List view of documents, Just click on the document file name to download it.

Manage documents

Common action performed on the module

  • Click on List text box in the top → click on Create New option beside the LISTS to create custom filters.

  • Click on More→ Apply the desired action

    • Documents Fields & Layout → To configure the module fields and customize the field layouts. Module Layouts & Fields

    • Document Workflows → To add workflows related to your Task and Events.

    • Document Picklists Values → To modify the picklist values

    • Document Numbering → To create custom numbering for records

Action performed in the list view of the calendar

  • Click on the Search icon in right corner of the list view table → To search for records in that module

  • Click on the Box icon in right corner of the list view table → To alter the header menu

  • Double click on the menu → To sort the menu.

  • Bulk actions on the whole - Select the desired records → click on the Drop down menu and the choose the necessary menu

    • Move - To move records from one folder to another.

    • Follow → To keep track of the document

    • UnFollow → Disable when you no longer need to track a document

    • Add Tag → To add different tag for the selected records

    • Edit icon → To edit the selected records on the whole (Mass Edit)

    • Delete→ To Delete the selected records(bulk deletion)
  • Actions done on single record

    • Enable the STAR icon to follow(keep track of) a document. Disable it to unfollow.

    • Click on the drop down in the right corner of each record

      • Details → Navigate to the detail view of the record

      • Edit → To edit the record

      • Delete → To delete the selected record

Action performed in the detail view of any document

  • Click on Add Tag → To add a new tag

  • Edit → To edit the document

  • Click on More and choose the necessary option

    • Delete Document → To delete the record information

    • Duplicate → To replicate the already existing record to create a new one.

    • Check file integrity →To check your documents integrity